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Note: This procedure would be used when the magnet being referenced is in place in the Beamline and all the planes are not visible, (i.e. against the wall or close to the floor or close to another magnet.)
Note: this procedure assumes a freshly calibrated Laser Tracker and the instrument is in a good location for measuring the component.

1. A well distributed network of pass points must be located around the component to be referenced. A minimum of six is desired if they can all be observed from each instrument location.

2. Open Spatial Analyzer software.

3. Create folder named “Beamline_Magnet Ref.”. (ex. NuMI_Magnet Ref)

4. Save file named “Magnet Ser. No._Date”.

5. Choose from the task bar, Instrument>Add.

6. In the Add Instrument window, highlight the Tracker type and stand you are using. 

7. Check the Run the Instrument Interface Module box and click Add Instrument to Job. Dock the tracker pad by clicking on docking button. Home the instrument.

Note: Begin by measuring the pass points.

8. Type “Control” into Group box on tracker pad.

9. Measure desired control points (pass points) with Measurement Profile set on Two Face. After measuring all control points visible from this instrument location, track to home and check closure by clicking on Check/Cal>Closure on task bar. Verify acceptable closure value and click Log and Click OK. Hit Home. Note: It is good practice to continue making closure checks in this manner throughout the survey.

Note: We will now measure all visible planes.

10. Type “Name of Plane” into Group box. (ex. DNST)

11. Type “Name of Plane_1” into Target box. (ex. DNST_1)

12. Measure a minimum of 4 points on each plane, with Measurement Profile set on Single Pt To SA on tracker pad, trying to cover as much of the plane as possible.

Note: in most cases, it will be possible to see one plane in each dimension from the same setup. (ex. TOP or z plane, LEFT or x plane, UPST or y plane.

13. After measuring all planes visible from this instrument location, track to home and check closure by clicking on Check/Cal>Closure on task bar. Verify acceptable closure value and click Log and Click OK. Hit Home.

14. Hit F6 to change face. Re-measure each plane in reverse remembering to enter proper plane name in Group box and properly incremented point name in Target box.

Note: We will now measure all visible fiducials.

15. Type “Fids0” in Group box.

16. Type “Fiducial Name” in Target box. (ex. MagnetSerNo_A)

17. Home instrument. Reset Measurement Profile to Two Face.

18. Measure all visible fiducials, remembering to change name in Target box to corresponding fiducial being measured.

Note: In most cases, it will be possible to see all of the fiducials from this set-up. 

19. Choose from task bar, Instrument>Drift Check.

20. Double click on Control group.

21. Type DriftCheck0 in Group To Contained Measured Points box. Hit Apply.

22. Measure a minimum of 3 well distributed points in the Control group.

23. If results are acceptable, hit Finished-Drift Acceptable. (Note: if not, set-up may need to be repeated.)

(Note: it is advisable to perform plane fits to determine if any bad measurements have been taken before moving the instrument. After checking, hit Cancel as final planes will be built later.)

24. Close tracker pad.

25. Move tracker to new location for measurement of unobserved planes and fiducials.

26. Repeat steps 5 through 7.

27. Locate Instrument by choosing from task bar, Instrument>Locate (Transform to Part)>Measure Nominal Points.

28. Double click on Instrument 1 when prompted.

29. Double click on Control group.

30. Type BFIT1 into Group to Contain Measured Points box and click Apply.

31. Measure desired pass points. When complete choose Finished-Locate Instrument.

Note: Assuming proper positioning of the instrument on the first setup, all three planes have been measured. If this is the case, this second setup is only for the purpose of measuring a second redundant ray into the fiducials for verification of referencing. In this case, only repeat steps 15 through 24, remembering to increment the measured group to “Fids1”, then skip to 33. If there are still planes to measure, continue with step 32.

32. Repeat steps 10 through 32 until conditions in 33 are met, remembering to increment group names so the number matches the instrument number of the set-up.

Note: this prevents overwriting of measured points with the same name and allows bundling of the redundant points later.

Note: You can skip 25 through 32 on the last setup.

33. If all planes are measured and all fiducials have a minimum of two rays, the measurements are complete. 

34. If these conditions are not met, repeat steps 10 through 24, remembering to increment the Instrument.

Note: We will now bundle the measurements.

35.  If the conditions in step 33 are met, choose Analysis>Coordinate Uncertainty>Unified Spatial Metrology Network. 

36. Choose F2, select All in Select Instrument window, select OK.

37. Select Enter.

38. Select Exclude Measurements.

39. Check all points that are not pass-points or fiducials. Also, check all Drift Checks.

40. Choose OK.

41. Choose Yes in Spatial Analyzer window.

42. Choose Best-Fit then Solve.

43. In the Apply Results section of the USMN window, type FINAL after USMN Composite. This names the final bundle.

44. Choose Apply.

Note: For ease of plane construction, we will create a Point on Positive frame so that all of the Planer Offsets in the Default Plane are in the same direction.

45. On tracker pad, type POP in Group box, and POP1 in Target box.

46. Choose Single Pt. in Measurement Profile box.

47. Track the prism to a point on the station face, either upstream or downstream, of the existing magnet and near beam centerline. Hit measure.

48. Measure another point upstream or downstream of the existing magnet and near centerline, this will be automatically named POP2.

49. Choose from task bar; Construct>Frame>Using Points and Vectors.

50. Double Click POP1.

51. In the Primary Axis section of the Frame from Points and Vectors box, choose Point for Defined by: and +Y or -Y for Axis, depending on the direction of POP2. Hit Continue.

52. Double Click POP2.

53. In the Secondary Axis section of the Frame from Points and Vectors box, choose Vector for Defined by: and +Z for Axis. Hit Continue.

54. Double Click the WORLD Frame. 

55. In the Frame window, type POP in the Name: box.

56. Choose Update.

57. Choose Make Working.

58. Choose Transform.

59. In the Frame Position box, enter the approximate half-size of the magnet in the Y box. The sign of this value should be opposite the sign of the Y axis chosen in Step 51. Make sure you use the proper units.

60. Choose Update.

61. Close the Frame Position and Frame windows.

Note: There is now an active frame in the approximate center of the magnet in the proper orientation. You are now ready to construct the magnet planes.

62. Choose Construct>Plane>Fit to Points from the task bar.

63. Hit F2 and check all the measurements to one of the planes.

64. Hit OK. Hit Enter.

65. In the Plane Fit window, hit the big check box at the top between the question mark and the Re-Fit button. This is the Default Plane window. In this window choose Point on Pos. Side in the Normal Direction section. In the Measured section, choose the proper graphic showing the SMR location relative to both the plane measured and the normal arrow, remembering that the normal arrow points toward the origin of the frame. In the Planer Offset section, make sure that the proper prism radius is chosen. Hit the Output Parameters and make sure that Make Cardinal Pts., Make Offset Pts., and Make Geometry are checked. Hit OK.

66. OK the Default Plane.

67. Hit the Re-Fit button. 

68. OK the Plane Fit.

69. Name the plane in the Group Name for Offset Points in the Input window. Hit OK.

70. Do the same for the Group Name for Cardinal Points. Hit OK.

71. Name the plane in the Plane window. Hit Update. Hit Close.

72. Repeat steps 62 through 71 for all other measured planes.

Note: We will now construct the other station plane which will be used in the construction of the MAGNET frame.

73. Right click on the UPST or DNST plane that was created.

74. Click Copy. Click Update in Copy Objects window. Close window.

75. Right click on the UPST or DNST copied plane. Click Properties. Click shift. Enter the magnet length in the Shift Along Normal box of the Shift Plane window. Hit OK.

76. Hit Update and Close in Plane window. This process will construct another plane at the other end of the magnet from the measured plane. 

Note: Repeat steps 73 through 76, choosing LEFT, RIGHT, or TOP, BOTTOM measured planes and entering the magnet half size in the Shift Along Normal box of the Shift Plane window. This process will construct a mid-plane at the center of the magnet in the X and Z direction.

77. Right click on each newly created plane.

78. Click Properties.

79. Type the new plane name in the Name section of the Plane window. (ex. UPST or DNST, VERT_MID for TOP, BOTTOM, or HORZ_MID for LEFT, RIGHT).

80. Click Update. Click Close.

81. Repeat steps 77 through 80 for the other two copied planes.

Note: We will now construct the magnet centerline.

82. Choose Construct>Line>2 Plane Intersection from task bar.

83. Double click HORZ_MID.

84. Double click VERT_MID.

85. Type Centerline for Name in Line window. Hit Update. Hit Close.

86. Choose Construct>Point(s)>Intersection>Line and Plane from task bar.

87. Double Click Centerline line and double click Upst plane.

88. Enter MagnetSerNo_UP for Point Name in Construct New Point window. Also, rename Main to CALCS in Group box.

Note:  Repeat steps 86 through 88 choosing the Dnst plane and naming the new point MagnetSerNo_DN.

Note: Now construct the origin of the magnet frame.

89. Choose Construct>Point>Fit to Points from task bar. Double click on MagnetSerNo_UP and MagnetSerNo_DN. Hit enter.

90. In the Construct New Point window, name the point MagnetSerNo_CT.

Note: We will now construct the MAGNET frame.

91. Choose Construct>Frame>Using Points and Vectors from the task bar.

92. Double click on MagnetSerNo_CT point.

93. In the Primary Axis section of the Frame from Points and Vectors box, choose Point for Defined by: and +Y for Axis. Hit Continue.

94. Double Click MagnetSerNo_DN.

95. In the Secondary Axis section of the Frame from Points and Vectors box, choose Vector, for Defined by: and +Z or -Z, depending on the normal direction of measured Z plane, (ex. TOP or BOTTOM), for Axis. Hit Continue.

96. Double Click the measured Z plane, (ex. TOP or BOTTOM).  

97. In the Frame window, type MAGNET in the Name box.

98. Choose Update.

99. Choose Make Working.

Note: check the direction of the Z vector in the MAGNET frame. Rotate the frame accordingly by right clicking on MAGNET frame, choosing properties, choosing Transform, and entering 180 in RY box of Orientation section of Frame Position window. Close Frame Position and Frame windows. The MAGNET frame is now at the center of the magnet with the proper axis orientation for giving correct reference numbers for the magnet fiducials.

100. Choose Edit>Group Manager from the task bar.

101. Click on USMN Composite FINAL group in the left side of the Group Manager window.

102. Highlight the magnet fiducials.

103. Right click in the highlighted area and choose Copy selections into a New Group.

104. Type Export in to the Group box in the Rename Object window. Hit OK.

105. Click on CALCS group in the left side of the Group Manager window.

106. Highlight the MagnetSerNo_UP, DN, and CTR points. 

107. Right click in the highlighted area and choose copy.

108. Click on the newly created Export group. Right click and paste the three magnet points into this group and close Group Manager window.

109. Right click on Export group name.

110. Click Export to ASCII File.

111. Browse to proper folder and type MagnetSerNo_REF.txt in File Name box of Save As window. Hit Save.

112. In the ASCII Export window; choose Comma Delineated for the Separator, Target for the Target Name, and check Include SA version and working frame comments. Hit OK. Close the Notepad window.

113. Choose File>Save.

114. Choose File>Backup Now.

